Автор Тема: Воспроизведение роликов Youtube на полный экран  (Прочитано 933 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Philipp

  • Администратор
  • *****
  • Сообщений: 2 153
  • Пол: Мужской
  • С Администратором лучше не спорить.
Давно заметил, что ролики Youtube на некоторых сайтах и форумах перестали открываться для воспроизведения на полный экран с сообщением при нажатии на полноэкранную кнопку "не удалось перейти в полноэкранный режим".
При этом есть ссылка на справку где ничего по этому поводу не говорится. В окне всё воспроизводится нормально и это же видео на самом Ютубе тоже без проблем на полный экран.
При этом на многих сайтах такой проблемы не возникает.

Поиск в интернете даёт рекомендации на настройки браузеров, флешплеера и акаунта Ютуб. Пробовал безрезультатно.
Только в одном месте нашёл ключевую фразу, что полноэкранное воспроизведение видео может быть запрещено на самом сайте. Значит на нашем форуме где то это настраивается? Причём ранее, мне кажется, полноэкранное воспроизведение работало.

Прошёлся по настройкам - не нашёл.
Зашёл на русскоязычный форум по нашему движку форума https://www.simplemachines.ru/index.php поискал безрезультатно.

Данная особенность отсутствия воспроизведения видео на полный экран сразу на форуме неудобна и ведёт к уходу с форума пользователей.

Не знаю что делать и прошу помощи у Вас так как знаю что среди нас есть специалисты лучше меня или просто более внимательные люди. Предполагаю, что это какая то настраиваемая опция форума и надо просто откопать её.

Оффлайн Doctor Hedron

  • Постоялец
  • ***
  • Сообщений: 165
  • Пол: Мужской
Попробовал сейчас потыкать в разные ютуб-видео в постах на форуме - всё отлично открывается в полный экран. Последняя версия Firefox (автоапдейт).

Цитировать
"не удалось перейти в полноэкранный режим"

Всплывашка от браузера, или прямо в плеере ютуба пишет? Плеер флеш или хтмл5? Можете дать еще пару примеров других сайтов, где такое же поведение?

Апд.: залез сейчас в исходный код страницы форума, где есть ютуб-видео в посте. Всё нормально:

Цитировать
<embed src="http://www.youtube.com/v/lodYYRgkvX0&amp;rel=1&amp;fs=1" type="application/x-shockwave-flash" allowFullScreen="true" allowScriptAccess="never" wmode="transparent" width="425px" height="350px"><noembed><a href="http://www.youtube.com/watch?v=lodYYRgkvX0" target="_blank">http://www.youtube.com/watch?v=lodYYRgkvX0[/url]</noembed></embed>

Может ли быть, что вы сами однажды в браузере нажали что-то вроде "запрещать флеш-плееру переходить в полный экран на этом сайте"?
« Последнее редактирование: 19 Мая 2018, 22:39:40 от Doctor Hedron »

Оффлайн Philipp

  • Администратор
  • *****
  • Сообщений: 2 153
  • Пол: Мужской
  • С Администратором лучше не спорить.
Выглядит это так после нажатия кнопки полноэкранного режима во время воспроизведения.



Сейчас у меня стоит Яндекс браузер. До него был с тем же дефектом Хром. Удалён сейчас.
Ещё стоял, сносился и опять установлен давно Интернет Эксплорер. В нём вообще странность увидел. На месте окна для Ютуб видео пусто вообще. Только место в посте под него и не нать мне он года не прошло как, достал последние годы.
В Майкрософт Эйдже как и в Яндексе нет полноэкранного режима.

Стоял по требованию обновить Флешплеер 32 бита. Снёс сегодня. Яндекс зачем то разок опять попросил его обновить и продолжил работать как и раньше, но без него.
Ютуб сам сайт в полный экран работает всегда и везде без проблем особых.
« Последнее редактирование: 20 Мая 2018, 12:10:56 от Philipp »

Оффлайн Doctor Hedron

  • Постоялец
  • ***
  • Сообщений: 165
  • Пол: Мужской
Ютуб раньше был целиком на флеше, потом они перешли на хтмл5, но флеш остался:

- для случаев, когда что-то недогрузилось, сломалось, у пользователя древний браузер и т.д. (фоллбек на всякий случай, в общем)
- для древнего кода вставки видео на многих форумах (вот как на этом форуме), который делался через embed флешплеера, но сейчас они вроде насильно отдают в ответ хтмл5-плеер, а не флеш

Попробуйте вот что: сохраните это как хтмл-файл и откройте в браузере.

<html>
<body>
Старый код вставки видео:<br><br>
<embed src="http://www.youtube.com/v/lodYYRgkvX0&amp;rel=1&amp;fs=1" type="application/x-shockwave-flash" allowFullScreen="true" allowScriptAccess="never" wmode="transparent" width="425px" height="350px"></embed>
<br><br>Новый код вставки видео:<br><br>
<iframe width="560" height="315" src="https://www.youtube.com/embed/lodYYRgkvX0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
</body>
</html>

Тут два разных способа вставить ютуб-плеер на страницу. Работает ли полноэкранный режим хотя бы в одном из них?

Кстати, у других участников нормально все работает? Можно протестировать на вот этом сообщении с видео.

P.S.
Цитировать
Интернет Эксплорер. В нём вообще странность увидел. На месте окна для Ютуб видео пусто вообще. Только место в посте под него и не нать мне он года не прошло как, достал последние годы.
Это похоже на просто отсутствующий флеш, или плагин в ИЕ отключен (вручную или из-за того, что сильно устарел, например).

Оффлайн grigr

  • Глобальный модератор
  • *****
  • Сообщений: 3 123
  • Пол: Мужской
  • кручу-верчу
    • Мой Магазин
у меня выдал так: в Хроме

Оффлайн grigr

  • Глобальный модератор
  • *****
  • Сообщений: 3 123
  • Пол: Мужской
  • кручу-верчу
    • Мой Магазин
а вот в ФФ сразу все заработало

Оффлайн Philipp

  • Администратор
  • *****
  • Сообщений: 2 153
  • Пол: Мужской
  • С Администратором лучше не спорить.
Яндекс на движке Хрома сделан...